17 de Julio de 2018, 12:54:11 am
  • WPSdb - Base de Datos de Pines Online

Autor Tema: Metasploit Framework  (Leído 2189 veces)

Desconectado D3M0N

  • Founder
  • Usuario
  • *
  • Mensajes: 3.139
  • Reputación: +252/-500
  • El Mate, La Netbook y Wi-Fi del Vecino!
  • awards Usuario con más de 2000 Posts! Miembro registrado desde 2010 Usuario Registrado
    • Arg-Wireless.com.ar
    • Awards
Metasploit Framework
« en: 01 de Mayo de 2011, 01:48:56 am »
El Proyecto Metasploit es un proyecto open source de seguridad informí¡tica que proporciona informaciín acerca de vulnerabilidades de seguridad y ayuda en tests de penetraciín y en el desarrollo de firmas para Sistemas de Detecciín de Intrusos. Sus subproyecto mí¡s conocido es el Metasploit Framework, una herramienta para desarrollar y ejecutar exploits contra una mí¡quina remota. Otros subproyectos importantes son la bases de datos de opcodes (cídigos de operaciín), un archivo de shellcodes, e investigaciín sobre seguridad. Inicialmente fue creado utilizando el lenguaje de programaciín de scripting Perl, aunque actualmente el Metasploit Framework ha sido escrito de nuevo completamente en el lenguaje Ruby.

INSTALACIí“N:

dependencias a instalar:

Código: [Seleccionar]
sudo apt-get install ruby libruby rdoc
sudo apt-get install libyaml-ruby
sudo apt-get install libzlib-ruby
sudo apt-get install libopenssl-ruby
sudo apt-get install libdl-ruby
sudo apt-get install libreadline-ruby
sudo apt-get install libiconv-ruby
sudo apt-get install rubygems
sudo apt-get install libmysqlclient-dev
sudo apt-get install ruby1.8 libopenssl-ruby1.8 rails

Código: [Seleccionar]
sudo gem install -v=1.2.2 rails

crear el directorio "MSF" en /opt/MSF:

Código: [Seleccionar]
sudo mkdir /opt/MSF

entrar al directorio:

Código: [Seleccionar]
cd /opt/MSF

instalar metasploit:

Código: [Seleccionar]
sudo svn co http://metasploit.com/svn/framework3/trunk/

para arrancarlo nos colocamos en el directorio /opt/MSF/trunk:

Código: [Seleccionar]
cd /opt/MSF/trunk

y lo ejecutamos

Código: [Seleccionar]
sudo ./msfconsole

actualizarlo:

Código: [Seleccionar]
sudo svn update

VIDEO INTALACIí“N:
  • Antenas: Antena Komarov (Prototype), Antena Belgrain (MOD), Antenas 4, 5, 9dBi (omnis)
  • Sistemas Operativos: Microsoft Windows 7 Enterprice (x64), Ubuntu 14.10.1 LTS Desktop Edition 64-bit
  • Sistemas Operativos que utilizo para Auditar: Ubuntu 14.10.1 LTS Desktop Edition 64-bit
  • Dispositivos Inalambricos: Alfa AWUS036H 1W (USB); TP-Link TL-WN722N (USB); Ubiquiti Nanostation M2; Mikrotik RB951Ui-2HnD

Desconectado fragaycia

  • Usuario
  • *
  • Mensajes: 6
  • Reputación: +0/-0
  • Usuario
  • awards Usuario Registrado
    • @fragaycia
    • Awards
Re:Metasploit Framework
« Respuesta #1 en: 07 de Mayo de 2011, 04:15:47 pm »
Buen tutorial, es el que seguí­ para instalar tras el formateo. Pero tengo una duda.
No soy capaz de hacer que soporte sqlite3. ¿Se sabe si se retirí este tipo de DB en la íltima versiín?

Un saludo.